Configurazione Cisco 837


Questa è la configurazione per il cisco 837 che utilizzo, con questa ho ottenuto un qos perfetto per il voip, molto meglio di quello che si ottiene usando il policy-map che nel mio listato e’ presente ma non piu’ usato. Adesso per il qos dedicato al voip le righe influenti sono:

ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave

più qualche altra riga per un fine tuning.

La configurazione la utilizzo per una connessione con NGI F5 e utilizzo il servizio VOIP sempre di NGI chiamato SQUILLO (vabbe’ il nome non e’ proprio un granchè).

Qui sotto il listato della mia conf con le password da cambiare.

Current configuration : 4034 bytes
!
! Last configuration change at 14:13:04 CET Tue Nov 21 2006 by admin
! NVRAM config last updated at 14:13:15 CET Tue Nov 21 2006 by admin
!
version 12.4
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
service sequence-numbers
!
hostname Router
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
no logging buffered
enable secret
!
no aaa new-model
!
resource policy
!
clock timezone CET 1
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.1 10.0.0.9
!
ip dhcp pool CLIENT
network 10.0.0.0 255.255.255.0
default-router 10.0.0.5
domain-name naghouse
dns-server 88.149.128.12 88.149.128.22
lease 0 2
!
!
ip cef
no ip domain lookup
!
!
username admin

!
no crypto isakmp enable
!
interface Ethernet0
ip address 10.0.0.5 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip mroute-cache
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
load-interval 30
atm ilmi-keepalive 10
dsl operating-mode auto
pvc 8/35
tx-ring-limit 3
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer1
bandwidth 256
ip address negotiated
ip accounting precedence output
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap hostname
ppp chap password ppp pap sent-username password ppp ipcp dns request
ppp ipcp wins request
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
hold-queue 224 in
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
no ip http secure-server
!
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 10.0.0.1 20 interface Dialer1 20
ip nat inside source static tcp 10.0.0.1 21 interface Dialer1 21
ip nat inside source static tcp 10.0.0.1 4711 interface Dialer1 4711
ip nat inside source static tcp 10.0.0.1 5900 interface Dialer1 5900
ip nat inside source static udp 10.0.0.1 5671 interface Dialer1 5671
ip nat inside source static tcp 10.0.0.1 5665 interface Dialer1 5665
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 23 permit any
access-list 102 permit ip 10.0.0.0 0.0.0.255 any
access-list 103 remark ANTI-SPOOFING
access-list 103 deny ip host 0.0.0.0 any log
access-list 103 deny ip 127.0.0.0 0.255.255.255 any log
access-list 103 deny ip 10.0.0.0 0.255.255.255 any log
access-list 103 deny ip 172.16.0.0 0.15.255.255 any log
access-list 103 deny ip 192.168.0.0 0.0.255.255 any log
access-list 103 deny ip 224.0.0.0 31.255.255.255 any log
access-list 103 deny icmp any any redirect log
access-list 103 permit ip any any
dialer-list 1 protocol ip permit
!
!
control-plane
!
banner login ^CCAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
exec-timeout 120 0
no modem enable
transport output all
stopbits 1
line aux 0
transport output all
stopbits 1
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
transport input all
transport output all
!
scheduler max-task-time 5000
sntp server 193.204.114.105
end

No tag for this post.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *